[Webfunds-commits] java/webfunds/client WalletContext.java

Ian Grigg iang@cypherpunks.ai
Sat, 10 Jun 2000 16:01:33 -0400 (AST)


iang        00/06/10 16:01:33

  Modified:    webfunds/client WalletContext.java
  Log:
  public not needed for interfaces... ?

Revision  Changes    Path
1.9       +6 -6      java/webfunds/client/WalletContext.java

Index: WalletContext.java
===================================================================
RCS file: /home/webfunds/cvsroot/java/webfunds/client/WalletContext.java,v
retrieving revision 1.8
retrieving revision 1.9
diff -u -r1.8 -r1.9
--- WalletContext.java	2000/06/10 18:29:44	1.8
+++ WalletContext.java	2000/06/10 20:01:33	1.9
@@ -1,4 +1,4 @@
-/* $Id: WalletContext.java,v 1.8 2000/06/10 18:29:44 iang Exp $
+/* $Id: WalletContext.java,v 1.9 2000/06/10 20:01:33 iang Exp $
  *
  * Copyright (c) 2000 Systemics Inc. All rights reserved.
  */
@@ -17,14 +17,14 @@
 public interface WalletContext
 {
     /** how to interpret low level names to printable names */
-    public Addressbook getAddressbook(WalletInterface wi);
-    public SecureRandom getSecureRandom();
+    Addressbook getAddressbook(WalletInterface wi);
+    SecureRandom getSecureRandom();
     /** the persistant storage object available from client */
-    public Store getStore(WalletInterface wi) throws StoreException;
+    Store getStore(WalletInterface wi) throws StoreException;
     /** the GUI */
-    public UInterface getUInterface(WalletInterface wi);
+    UInterface getUInterface(WalletInterface wi);
     /** the PluginManager for modifying the GUI's menus */
-    public PluginManager getPluginManager(WalletInterface wi);
+    PluginManager getPluginManager(WalletInterface wi);
 
 
     // XXX: ChangeContractStore is misnamed and prolly too specific.