[Webfunds-commits] java/webfunds/client WalletContext.java

Ian Grigg iang@cypherpunks.ai
Sat, 10 Jun 2000 14:29:45 -0400 (AST)


iang        00/06/10 14:29:45

  Modified:    webfunds/client WalletContext.java
  Log:
  needed public for external wallets?  added comments...

Revision  Changes    Path
1.8       +10 -6     java/webfunds/client/WalletContext.java

Index: WalletContext.java
===================================================================
RCS file: /home/webfunds/cvsroot/java/webfunds/client/WalletContext.java,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -r1.7 -r1.8
--- WalletContext.java	2000/06/05 03:48:15	1.7
+++ WalletContext.java	2000/06/10 18:29:44	1.8
@@ -1,4 +1,4 @@
-/* $Id: WalletContext.java,v 1.7 2000/06/05 03:48:15 gelderen Exp $
+/* $Id: WalletContext.java,v 1.8 2000/06/10 18:29:44 iang Exp $
  *
  * Copyright (c) 2000 Systemics Inc. All rights reserved.
  */
@@ -16,11 +16,15 @@
 
 public interface WalletContext
 {
-    Addressbook getAddressbook(WalletInterface wi);
-    PluginManager getPluginManager(WalletInterface wi);
-    SecureRandom getSecureRandom();
-    Store getStore(WalletInterface wi) throws StoreException;
-    UInterface getUInterface(WalletInterface wi);
+    /** how to interpret low level names to printable names */
+    public Addressbook getAddressbook(WalletInterface wi);
+    public SecureRandom getSecureRandom();
+    /** the persistant storage object available from client */
+    public Store getStore(WalletInterface wi) throws StoreException;
+    /** the GUI */
+    public UInterface getUInterface(WalletInterface wi);
+    /** the PluginManager for modifying the GUI's menus */
+    public PluginManager getPluginManager(WalletInterface wi);
 
 
     // XXX: ChangeContractStore is misnamed and prolly too specific.