[Webfunds-commits] java/webfunds TODO_SCW

Ian Grigg iang@cypherpunks.ai
Tue, 22 Aug 2000 21:30:39 -0400 (AST)


iang        00/08/22 21:30:39

  Modified:    webfunds TODO_SCW
  Log:
  update from testing!

Revision  Changes    Path
1.7       +52 -55    java/webfunds/TODO_SCW

Index: TODO_SCW
===================================================================
RCS file: /home/webfunds/cvsroot/java/webfunds/TODO_SCW,v
retrieving revision 1.6
retrieving revision 1.7
diff -u -r1.6 -r1.7
--- TODO_SCW	2000/08/21 08:24:49	1.6
+++ TODO_SCW	2000/08/23 01:30:39	1.7
@@ -5,10 +5,13 @@
       I.a)  Contract - all these can be repaired and saved on the fly
 
         + no trailing spaces (stripped in verify)
-Done??
+          (Done??)
+          (Not stripped from saved text, but minor point)
+
         + uniform line endings.  NB, the Contract code _rejects_
           _mixed_ line endings (for example \n followed by \r\n)
-Done??
+          (DONE, stripped all combinations)
+
         + all lines shorter or equal to 80 chars (not currently enforced)
         + Ricardian rules - sections, etc.
 
@@ -20,14 +23,13 @@
     
       I.b)  PKI
     
-        * top level signs contract signing key (and itself)
-Why not the server key?
+        * top level [cert] signs [contract] signing key (and itself)
         * contract signing key signs itself (and the contract, I.d below)
         * server key only signs itself
-        * keys have userIdTag strings: { "[contract]"  "[cert]"  "[server]"  }
-          as defined in
-          http://www.systemics.com/docs/ricardo/issuer/contract.html
-Uhm... this is not documented there.
+        * keys have userIdTag strings: { "[contract]"  "[cert]"  "[operator]"  }
+
+          tags are documented in
+          http://www.systemics.com/docs/ricardo/issuer/server-manage.html
     
       I.c) Secret Key
     
@@ -55,69 +57,64 @@
 
 II. Presentation. 
 
-        Some of the notes assume that the concept of "Wizard" is modifiable,
-        (as discussed...) which may be a bad assumption.
-
     a.  Contract should be written out in local format
         (with platform line ending, currently has ^M on Unix).
         (DONE)
 
-    b.  no title bar on window, something like Sign Contract Wizard
-        hard coded would be good. 
-        (DONE)
-
-    c.1 Browse starts in home directory not current directory? 
-        (DONE)
-
-    c.2 file names - asks for a file name for keys, but it must be
-        an absolute file name, not a relative file name from current
-        directory.  It would be preferable it if it could default to
-        to current directory if the filename did not start with the
-        pathname separator (some System. thing string that has / in it).
-        (DONE)
+        (Did not seem to change anything, still written with ^M
+        in Unix to *.asc and to *.txt...)
 
-    d.1 desperately need to save context somehow by either saving each
-        dialog contents out (messy) or by saving the contract fully out
-        and sucking the keys from there.  Testing cycle takes too long
-        otherwise, as have to type in all the info each time.
-
-        Problem with this is that it is a major new piece of work, so
-        desperation means nothing against lack of resource....
-
-    d.2 Needs a save button to save out that file to the original
-        Name or a browsed name.  Need to recall the name. 
-        (DONE)
-
-    d.3 Contract: Read File - does not describe state of contract, which must
+    b.  Contract: Read File - does not describe state of contract, which must
         be clean of PGP cruft, all from [keys] inclusive should be
         deleted manually.
         (DONE the instruction part, not the checking part)
      
         (Needs more support from Contract to do this checking as Contract.java
         can only read a signed Contract.)
+
+    c.  Bug: from "server" dialog, with nothing in the key name field,
+        pressing "Previous" resulting in exception message "Please select
+        a key" before switching back to previous screen.
 
-    d.4 better yet, it should use these as a starting point for the keys
-       (see d.1).
+III.  Coding comments (minor).
 
-    e.  Keys.   C&P box for keys would be nice...
+    + should have some manifest constant "eoln = "\r\n" for
+      better readability to describe the special newline that
+      is fixed for cleartext sigs (OpenPGP) and hashes (Ricardian
+      contracts)?
+      
+      Note: see System.getProperty("line.separator");
 
-    f.  Did we agree on a file format naming system?  TLA extensions?
-        (DONE: Use .asc for signed and .txt for unsigned)
+      (This is the local property, whereas the "\r\n" is special
+      OpenPGP standard (99%) newline for cleartext sigs, also used
+      (100%) by Ricardo for hashes.)
 
-    g.  Instructions for GPG would also be nice!
-        (DONE)
+IV.  Feature Requests!
 
-    h.  instructions: ... specify FILE NAME of where FILE contract is stored...
-        (DONE)
+        Some of the notes assume that the concept of "Wizard" is modifiable,
+        (as discussed...) which may be a bad assumption.
 
-    i.  Info:   add (Plugins / ContractBrowser) after
-                "whether it accepts the contract ()" 
-        (DONE)
+"A Signer" says:
+> I signed this with my commercial PGP instead of the wizard because the
+> wizard doesn't seem to recognize secring files and I want to be able to
+> use the secring and plain vanilla PGP for signing issuance orders
+
+    i) a.  Read Keys from secring and pubring files as stored
+           by popular PGP clients (mostly commercial NAI).  Would
+           involve checking for appropriate [tags] and presenting
+           a choice somehow if there are multiples?
 
-III.  Coding comments (minor).
+       b.  C&P box for keys would also be nice...
 
-    + should have some manifest constant "eoln = "\r\n" for
-      better readability?  See II.1st above.
-      
-      Note: see System.getProperty("line.separator");
-      
+    ii) desperately need to save context somehow by either saving each
+        dialog contents out (messy) or by saving the contract fully out
+        and sucking the keys from there.  Testing cycle takes too long
+        otherwise, as have to type in all the info each time.
+
+        Problem with this is that it is a major new piece of work, so
+        desperation means nothing against lack of resource....
+
+        "Ideal" way to do this is to firstly have save of contract
+        facilities (with keys appended) and secondly, to use keys
+        saved in (proto)contracts read in "Read File" as the keys
+        for later steps.