[Webfunds-commits] java/webfunds TODO_SCW TODO_SCW_prio

Edwin Woudt edwin@cypherpunks.ai
Mon, 21 Aug 2000 04:24:50 -0400 (AST)


edwin       00/08/21 04:24:50

  Modified:    webfunds TODO_SCW TODO_SCW_prio
  Log:
  Update

Revision  Changes    Path
1.6       +22 -5     java/webfunds/TODO_SCW

Index: TODO_SCW
===================================================================
RCS file: /home/webfunds/cvsroot/java/webfunds/TODO_SCW,v
retrieving revision 1.5
retrieving revision 1.6
diff -u -r1.5 -r1.6
--- TODO_SCW	2000/08/17 14:09:51	1.5
+++ TODO_SCW	2000/08/21 08:24:49	1.6
@@ -5,8 +5,10 @@
       I.a)  Contract - all these can be repaired and saved on the fly
 
         + no trailing spaces (stripped in verify)
+Done??
         + uniform line endings.  NB, the Contract code _rejects_
           _mixed_ line endings (for example \n followed by \r\n)
+Done??
         + all lines shorter or equal to 80 chars (not currently enforced)
         + Ricardian rules - sections, etc.
 
@@ -19,11 +21,13 @@
       I.b)  PKI
     
         * top level signs contract signing key (and itself)
+Why not the server key?
         * contract signing key signs itself (and the contract, I.d below)
         * server key only signs itself
         * keys have userIdTag strings: { "[contract]"  "[cert]"  "[server]"  }
           as defined in
           http://www.systemics.com/docs/ricardo/issuer/contract.html
+Uhm... this is not documented there.
     
       I.c) Secret Key
     
@@ -49,24 +53,28 @@
     BUT, earlier checking of these conditions would be good too.
 
 
-II. Presentation.
+II. Presentation. 
 
         Some of the notes assume that the concept of "Wizard" is modifiable,
         (as discussed...) which may be a bad assumption.
 
     a.  Contract should be written out in local format
         (with platform line ending, currently has ^M on Unix).
+        (DONE)
 
     b.  no title bar on window, something like Sign Contract Wizard
-        hard coded would be good.
+        hard coded would be good. 
+        (DONE)
 
-    c.1 Browse starts in home directory not current directory?
+    c.1 Browse starts in home directory not current directory? 
+        (DONE)
 
     c.2 file names - asks for a file name for keys, but it must be
         an absolute file name, not a relative file name from current
         directory.  It would be preferable it if it could default to
         to current directory if the filename did not start with the
         pathname separator (some System. thing string that has / in it).
+        (DONE)
 
     d.1 desperately need to save context somehow by either saving each
         dialog contents out (messy) or by saving the contract fully out
@@ -77,11 +85,13 @@
         desperation means nothing against lack of resource....
 
     d.2 Needs a save button to save out that file to the original
-        Name or a browsed name.  Need to recall the name.
+        Name or a browsed name.  Need to recall the name. 
+        (DONE)
 
     d.3 Contract: Read File - does not describe state of contract, which must
         be clean of PGP cruft, all from [keys] inclusive should be
         deleted manually.
+        (DONE the instruction part, not the checking part)
      
         (Needs more support from Contract to do this checking as Contract.java
         can only read a signed Contract.)
@@ -92,15 +102,22 @@
     e.  Keys.   C&P box for keys would be nice...
 
     f.  Did we agree on a file format naming system?  TLA extensions?
+        (DONE: Use .asc for signed and .txt for unsigned)
 
     g.  Instructions for GPG would also be nice!
+        (DONE)
 
     h.  instructions: ... specify FILE NAME of where FILE contract is stored...
+        (DONE)
 
     i.  Info:   add (Plugins / ContractBrowser) after
-                "whether it accepts the contract ()"
+                "whether it accepts the contract ()" 
+        (DONE)
 
 III.  Coding comments (minor).
 
     + should have some manifest constant "eoln = "\r\n" for
       better readability?  See II.1st above.
+      
+      Note: see System.getProperty("line.separator");
+      



1.4       +16 -16    java/webfunds/TODO_SCW_prio

Index: TODO_SCW_prio
===================================================================
RCS file: /home/webfunds/cvsroot/java/webfunds/TODO_SCW_prio,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- TODO_SCW_prio	2000/08/17 14:26:51	1.3
+++ TODO_SCW_prio	2000/08/21 08:24:49	1.4
@@ -28,22 +28,22 @@
 
 
 normal       io / sanity check filename entered for contract
-state: unknown
-
-normal       sanity / contract / remove wrong parts from read contract
-state: unknown
+state: fixed
 
-normal       text / readcontract / describe state (no [keys] etc...)
-state: unknown
-
 normal       functionality / add save clean contract file
-state: unknown
+state: fixed
 note: no save button!
 
 normal       text / finishsig / enter fileNAME
-state: unknown
+state: fixed
 
 normal       ui / make cancel button work
+state: fixed
+
+normal       text / readcontract / describe state (no [keys] etc...)
+state: fixed
+
+normal       sanity / contract / remove wrong parts from read contract
 state: unknown
 
 normal       format / contract / ricardian rules / 80, sections, spaces...
@@ -54,24 +54,24 @@
 
 
 minor        ui / no title bar
-state: unknown
+state: fixed
 note: hardcode 'Sign Contract Wizard'
 
 minor        text / congrat / reference plugins/contractbrowser, further instr
-state: unknown
+state: fixed
 
-minor        io / write contract in local format (no ^M on unix)
-state: unknown
-
 minor        ui / remember directory for browsing files
-state: unknown
+state: fixed (sort of, defaults to current directory)
 
+minor        io / write contract in local format (no ^M on unix)
+state: fixed
 
+
 enhancement  functionality / copy&paste box for keys
 state: unknown
 
 enhancement  text / instructions for gnupg
-state: unknown
+state: fixed
 
 enhancement  keys / read keys from contract if it contains valid pgp keys
 state: unknown